Fin du support de Ruby 2.1

En ce 1er avril 2017 s’arrête le support de la branche 2.1 de Ruby.

La série de versions 2.1.* était entrée en phase de maintenance de sécurité fin mars 2016, avec la sortie de la version 2.1.10. Cette phase était prévue pour durer un an, de sorte qu’aujourd’hui, la branche 2.1 n’est plus officiellement maintenue. Il n’y aura plus de commits, que ce soit de fonctionnalité, de correction de bug ou de traitement de faille de sécurité, sur cette branche. De ce fait, nous vous invitons à migrer vers Ruby 2.4 ou au minimum 2.3 sans attendre.

À propos des versions actuellement officiellement maintenues

Ruby 2.4.*

Cette branche est dans sa phase standard de support. Les correctifs fonctionnels et de sécurité sont backportés depuis master à mesure. Si une faille critique est découverte, un correctif sera mis à disposition le plus rapidement possible.

Ruby 2.3.*

Cette branche est dans sa phase standard de support. Les correctifs fonctionnels et de sécurité sont backportés depuis master à mesure. Si une faille critique est découverte, un correctif sera mis à disposition le plus rapidement possible.

Ruby 2.2.*

Cette branche est dans sa phase de support de sécurité. Il n’y a plus de backport depuis les ersions plus récentes, sauf pour des correctifs de sécurité. Si une faille critique est découverte, un correctif sera mis à disposition le plus rapidement possible. La fin du support pour cette branche se fera à la fin mars 2018.

Posté par usa le 2017-04-01
Traduit par Jean-Denis Vauguet